lunes, 14 de abril de 2014

Configuración de Vlans detrás de un router que sirve dhcp a cada vlan. CISCO

Pequeño ejercicio donde se representa el uso de las vlan tras un router que asigna el direccionamiento dhcp a cada vlan. Se uso el packet tracert para la configuración que se presenta a continuación.

Equipos:

Router: 2901
switch: 2960-24TT

Panorama:

Tanto en el primer piso como en el segundo se instalo un switch del modelo 2960 en donde los puertos del  1 al 10 pertenecen a la  vlan 10 y designado para el departamento de sistemas, los puertos del 11 al 20 pertenece a la vlan 20 y designado para la gente de gerencia.





              =================  Inicia Configuración del switch 1  =================  

Ponemos en modo trunk el puerto Gigabitethernet 1/1 y Gigabitethernet 1/2 (El 1/1 conecta con el router y el 1/2 conecta con el switch2)

switch1(config)#interface gigabitethernet 1/2
switch1(config-if)#switchport mode trunk
switch1(config-if)#switchport trunk allowed vlan all
switch1(config-if)#exit

switch1(config)#interface gigabitethernet 1/1
switch1(config-if)#switchport mode trunk
switch1(config-if)#switchport trunk allowed vlan all
switch1(config-if)#exit


Creamos la Vlans 10

switch1(config)#vlan 10
switch1(config-vlan)#name sistemas
switch1(config-vlan)#exit

Creamos la Vlans 20

switch1(config)#vlan 20
switch1(config-vlan)#name gerencia
switch1(config-vlan)#exit

Asignamos los puertos del 1 al 10 para que sean parte de la vlan 10

switch1(config)#interface range fastethernet 0/1-10
switch1(config-if-range)#switchport mode access 
switch1(config-if-range)#switchport access vlan 10
switch1(config-if-range)#exit

Asignamos los puertos del 11 al 20 para que sean parte de la vlan 20

switch1(config)#interface range fastethernet 0/11-20
switch1(config-if-range)#switchport mode access
switch1(config-if-range)#switchport access vlan 20
switch1(config-if-range)#exit

Verificamos la configuracion de las Vlans
switch1#show vlan


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig1/1

10   sistemas                         active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10

20   gerencia                         active    Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   


Grabamos la configuración del switch 1

switch1#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
switch1#

         =================  Termina Configuración del switch 1  =================  


          =================  Inicia Configuración del switch 2  =================  

Ponemos en modo trunk el puerto Gigabitethernet 1/2 (es el puerto que comunica con el switch 1)

switch2(config-if)#interface gigabitethernet 1/2
switch2(config-if)#switchport mode trunk
switch2(config-if)#switchport trunk allowed vlan all
switch2(config-if)#exit

Creamos la Vlans 10

Switch2 (config)#vlan 10
Switch2 (config-vlan)#name sistemas
Switch2 (config-vlan)#exit

Creamos la Vlans 20

Switch2 (config)#vlan 20
Switch2 (config-vlan)#name gerencia
Switch2 (config-vlan)#exit

Asignamos los puertos del 1 al 10 para que sean parte de la vlan 10

switch2(config)#interface range fastethernet 0/1-10
switch2(config-if-range)#switchport mode access
switch2(config-if-range)#switchport access vlan 10
switch2(config-if-range)#exit

Asignamos los puertos del 11 al 20 para que sean parte de la vlan 20

switch2(config)#interface range fastethernet 0/11-20
switch2(config-if-range)#switchport mode access
switch2(config-if-range)#switchport access vlan 20
switch2(config-if-range)#exit

Vemos como quedaron configuradas las Vlans

switch2#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig1/1, Gig1/2

10   sistemas                         active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10

20   gerencia                         active    Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   


Grabamos la configuración del switch 2

switch2#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
switch2#

             =================  Termina Configuración del switch 2  =================  

 =================  Inicia Configuración del ROUTER  =================  

Configuramos la interface gigabitethernet 0/0

Router(config)#interface gigabitethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit

Creamos una interfaz virtual para la vlan 10

Router(config-if)#    interface gigabitethernet 0/0.10    (el .10 es el número de la vlan)
Router(config-subif)# encapsulation dot1Q 10
Router(config-subif)# ip address 192.168.1.1 255.255.255.0
Router(config-subif)# exit


Creamos una interfaz virtual para la vlan 20

Router(config-if)#    interface gigabitethernet 0/0.20    (el .20 es el número de la vlan)
Router(config-subif)# encapsulation dot1Q 20
Router(config-subif)# ip address 192.168.2.1 255.255.255.0
Router(config-subif)# exit


Creamos los pools dhcp para la vlan 10

Router(config)#       ip dhcp pool vlan10
Router(dhcp-config)#  network 192.168.1.0 255.255.255.0
Router(dhcp-config)#  default-route 192.168.1.1
Router(dhcp-config)#  dns-server 192.168.1.1
Router(dhcp-config)#  dns-server 8.8.8.8
Router(dhcp-config)#  exit
Router(config)#       ip dhcp excluded-address 192.168.1.1


Creamos los pools dhcp para la vlan 20

Router(config)#       ip dhcp pool vlan20
Router(dhcp-config)#  network 192.168.2.0 255.255.255.0
Router(dhcp-config)#  default-route 192.168.2.1
Router(dhcp-config)#  dns-server 192.168.2.1
Router(dhcp-config)#  dns-server 8.8.8.8
Router(dhcp-config)#  exit
Router(config)#       ip dhcp excluded-address 192.168.2.1


Grabamos la configuración del router

Router# copy running-config startup
Destination filename [startup-config]? 
Building configuration...
[OK]
Router#

=================   Termina Configuración del ROUTER  =================  


Nota: el dhcp y como la totalidad de la configuración se plantearon para un escenario hipoteco, posiblemente no le sea útil para su necesidad, pero le puede dar idea de la solución.

4 comentarios:

  1. Hola amigo, realice la coniguracion para un pool dhcp tal como lo muestras pero no me libera direcciones. Alguna idea de que puede ser?

    ResponderEliminar
    Respuestas
    1. Saludos. ya realice algunas modificaciones a la configuración que se muestra aquí. pero el Pool dhcp debería funcionar sin problemas.

      Eliminar
  2. en la configuracion de la vlan 20 en el router el comando:
    Router(config-subif)# encapsulation dot1Q 10
    deberia ser
    Router(config-subif)# encapsulation dot1Q 20

    ResponderEliminar
    Respuestas
    1. Saludos. muchas gracias por el aviso, ya fue corregido.

      Eliminar